Supported Browsers

Attention Parents and all non-employee website users,

This is a friendly reminder that as of July 1st, 2014, SharpSchool no longer supports internet browsers that are older than Internet Explorer 8, Firefox 16, Chrome 26, Opera 12.1 or Safari 5.1

As we look to improve your product experience, we are moving past the support of older browsers. Firms like Google and Microsoft have already stopped supporting older versions of their own browsers. This is a technology trend that will continue with all web interfaces and one that will allow us to leverage new technology and capabilities.

To get the most functionality and usability out of your SharpSchool website, please update your internet browser to its most recent version.

You can update your browser by following the links below:

We apologize for any inconveniences this may cause but this is something we need to do in order to give you the best possible website experience.

Note: Waco ISD employees should not attempt to update the browsers on their work computers. The Technology Department has installed the browser(s) required to best suit our working needs.